No boot whitout screen

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
dref
Registered user
Registered user
Posts: 9
Joined: Thu May 09 2013 - 22:34:57
Location: france

No boot whitout screen

Postby dref » Thu May 09 2013 - 22:50:10

Hi,


The Raspberry Pi wont boot if there no monitor connected to it.
It need the monitor - On or Off - to boot. No problem with others distributions.

I've tried numerous time even with only the HDMI cable plugged on Rasberry - no boot.

But can reboot (shutdown via ssh) the Raspberry without a monitor attached. This is weird !

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 205
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: No boot whitout screen

Postby Exaga » Thu May 09 2013 - 23:18:02

dref wrote:Hi,


The Raspberry Pi wont boot if there no monitor connected to it.
It need the monitor - On or Off - to boot. No problem with others distributions.

I've tried numerous time even with only the HDMI cable plugged on Rasberry - no boot.

But can reboot (shutdown via ssh) the Raspberry without a monitor attached. This is weird !


Hi dref,

In the config.txt file I have the following entry, and find that booting and rebooting the RPi without a HDMI cable attached works every time:

hdmi_force_hotplug=1

There's an excellent source of information on the config.txt file over at eLinux.org - http://elinux.org/RPi_config.txt - if you're interested. ;)

Cheers,
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
dref
Registered user
Registered user
Posts: 9
Joined: Thu May 09 2013 - 22:34:57
Location: france

Re: No boot whitout screen

Postby dref » Thu May 09 2013 - 23:24:06

Thank you I've just read the link !

By the way what is the minimum value for this option:

Code: Select all

gpu_mem=32



8,4, 2, 0 ? I don't use a screen.

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 205
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: No boot whitout screen

Postby Exaga » Thu May 09 2013 - 23:35:49

dref wrote:Thank you I've just read the link !

By the way what is the minimum value for this option:

Code: Select all

gpu_mem=32


8,4, 2, 0 ? I don't use a screen.


Hi dref,

I believe the minimum value is gpu_mem=16. I've never seen any less value than 16 for video memory. :)

Cheers,
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
dref
Registered user
Registered user
Posts: 9
Joined: Thu May 09 2013 - 22:34:57
Location: france

Re: No boot whitout screen

Postby dref » Fri May 10 2013 - 06:50:11

Ok it work fine now, but I had to add a second ligne "hdmi_drive=2"
"hdmi_force_hotplug=1" alone wont work.


Code: Select all

# Use HDMI mode even if no HDMI monitor is detected
hdmi_force_hotplug=1

# Force the monitor to HDMI mode so that sound will be sent over HDMI cable
hdmi_drive=2


I found that here:
http://choorucode.com/2012/10/13/forcin ... i-at-boot/

User avatar
joe90
Registered user
Registered user
Posts: 4
Joined: Sat May 19 2012 - 15:47:49
Location: Noord-Holland

Re: No boot whitout screen

Postby joe90 » Fri May 10 2013 - 13:53:32

@ dref - it's also on http://elinux.org/RPiconfig too
Joe

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests