Config.txt

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
t0z
New member
New member
Posts: 1
Joined: Wed Jan 22 2014 - 22:52:22

Config.txt

Postby t0z » Wed Jan 22 2014 - 23:03:05

Hi, i installed slackarm successfuly on my pi but for some reason, my pi doesn't seem to read my config.txt at boot.

Running: Linux 3.10.27-arm.

rpi-update give:

*** ARM/GPU split is now defined in /boot/config.txt using the gpu_mem option!
*** Your firmware is already up to date

So, i got the latest.

config.txt:

gpu_mem=128

That's the only line in it.

And when i use "htop" i still get 231 allocated for RAM only.

Any taught?

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 204
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: Config.txt

Postby Exaga » Thu Jan 23 2014 - 15:13:41

Hi t0z,

I would delete the config.txt file and create it again, as root user, before rebooting. I have noticed sometimes the formatting is wrong and extra bytes are added to the filesize (especially if you've edited it in Windows with a third party text editor - or used wordpad (which you should never do). Also make sure the config.txt file and /boot/ directory is not set "read only" and that your SD card lock/unlock switch is not in the 'locked' position. Although if your SD card was locked it would crash at boot time. :D

Ensure you have the latest bootcode.bin, start*.elf and fixup*.dat files in your /boot directory. NB: there are 3 start*.elf files and 3 fixup*.dat files. You want them all in your /boot dir.

Other things to consider, your SD card itself. Have you tried a different SD card and found the same results?

Cheers,
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 2 guests