alsamixer on Slackware arm

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
Luca
Registered user
Registered user
Posts: 3
Joined: Fri Mar 14 2014 - 19:23:54

alsamixer on Slackware arm

Postby Luca » Fri Mar 14 2014 - 19:27:41

Hi all,
thanks foe the tutorial on installing Slackware arm on RasPi.

I got my Slack on my Raspi and it works fine!

Now I'd like to have audio output working...

the command alsamixer tell me:
cannot open mixer: No such file or directory

Is it possible to use audio output?

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 205
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: alsamixer on Slackware arm

Postby Exaga » Sat Mar 15 2014 - 10:25:01

Hi Luca,

Yes it's certain possible. You need to ensure you're using a USB soundcard that works. Take a look at the verified peripherals on elinux.org (http://elinux.org/RPi_VerifiedPeripherals#USB_Sound_Cards) where there are detailed instructions on how to install and configure them.

A bit of trial and error is required, as always. ;)
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
Luca
Registered user
Registered user
Posts: 3
Joined: Fri Mar 14 2014 - 19:23:54

Re: alsamixer on Slackware arm

Postby Luca » Mon Mar 17 2014 - 09:50:12

Hi Exaga,
thanks for your reply.

What do you think about using the on-board sound card of the Raspi?

I used it to play music with the official OS (Wheezy Raspbian). Is it possible with Slackware arm?

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 205
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: alsamixer on Slackware arm

Postby Exaga » Mon Mar 17 2014 - 23:09:03

Hi Luca,

Personally I've never needed to use the on-board sound running Slackware ARM on the Raspberry Pi. I don't see why it shouldn't work though, as long as the correct modules are loaded. If you're not having much success in getting it to work, this webpage may help: http://docs.slackware.com/howtos:hardware:sound_problems_on_slackware

It's certainly worth looking into. I may investigate myself at some point, as time allows.
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
Luca
Registered user
Registered user
Posts: 3
Joined: Fri Mar 14 2014 - 19:23:54

Re: alsamixer on Slackware arm

Postby Luca » Tue Mar 18 2014 - 09:55:45

Ok, that was the problem:

Code: Select all

modprobe snd_bcm2835


Now I have alsamixer working... Thanks again!

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 205
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: alsamixer on Slackware arm

Postby Exaga » Wed Mar 19 2014 - 00:55:39

No thanks needed Luca. You did it all by yourself. ;)

Glad you found the solution and managed to get the sound working.
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests