Latest firmware breaks I2C and SPI (plus other stuff).

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Latest firmware breaks I2C and SPI (plus other stuff).

Postby linicks » Sat Jan 31 2015 - 17:43:22

Updating my 3 Pi's today (kernel 3.18.5+), I noticed my RTC's stopped working - no /dev/i2c or /dev/rtc0 entries on reboot!

After a lot of messing around and googling, I found the reason/solution:

http://raspberrypi.stackexchange.com/qu ... -no-such-f

and read here:

http://www.raspberrypi.org/forums/viewt ... 58#p675658

Hope that helps someone.

Nick
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 204
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: Latest firmware breaks I2C and SPI (plus other stuff).

Postby Exaga » Sun Feb 01 2015 - 18:43:38

Thanks for the heads-up Nick.

I noticed that i2c is now incorporated into the kernel and a few other things have been included/changed too.
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests