Disable bash screen blanking

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
Kimdino
Registered user
Registered user
Posts: 11
Joined: Wed Aug 12 2015 - 03:50:25
Location: Dorset, UK

Disable bash screen blanking

Postby Kimdino » Wed Dec 23 2015 - 00:42:56

Hi folks,
How may I disable the screen saver? Note: this is purely in bash, I do not even have X installed. I have tried googling but all the answers I can find pertain either to X, or to a file that exists in Debian but not Slackware i.e. '/etc/kbd/config'.

grepping for 'blank' in /etc/ hasn't helped either.

Cheers, Kimdino

User avatar
Kimdino
Registered user
Registered user
Posts: 11
Joined: Wed Aug 12 2015 - 03:50:25
Location: Dorset, UK

Re: Disable bash screen blanking

Postby Kimdino » Wed Dec 23 2015 - 01:54:37

Hi again,

Sorry, ignore the above request. I had another thought after posting it and filtered the results of my grep with 'screen'. With the clutter removed I could then see the '/bin/setterm -blank 15 -powersave powerdown -powersave 60' line in '/etc/rc.d/rc.M'.

Currently I have set both the numeric terms to 0 and this worked. For the next reboot I will disabling this line entirely as I believe this may also remove any resource usage by the sreensaver.

Cheers, Kimdino

btw. Happy New Year to you all & I'll raise a glass to the FatDog staff for all the help they've given over the past year.

User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Re: Disable bash screen blanking

Postby linicks » Wed Dec 23 2015 - 21:28:13

Kimdino wrote:Hi again,

Sorry, ignore the above request. I had another thought after posting it and filtered the results of my grep with 'screen'. With the clutter removed I could then see the '/bin/setterm -blank 15 -powersave powerdown -powersave 60' line in '/etc/rc.d/rc.M'.

Currently I have set both the numeric terms to 0 and this worked. For the next reboot I will disabling this line entirely as I believe this may also remove any resource usage by the sreensaver.

Cheers, Kimdino

btw. Happy New Year to you all & I'll raise a glass to the FatDog staff for all the help they've given over the past year.


Ha. I never had this problem, but just looked on my Pi's and I did comment that line out on all of them - I must have hit this issue, like you and fixed it. I forget more than I know sometimes!

And kudos to:

"btw. Happy New Year to you all & I'll raise a glass to the FatDog staff for all the help they've given over the past year."

Me too, great job here for Slackers :)

Nick
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests