shutdown -r turning off rpi

The SARPi project forum. For anything and everything relating to Slackware ARM on a Raspberry Pi 1, 2, and 3. This forum is NOT a replacement or substitute for the Slackware (ARM) forums on Linux Questions website! Please try to seek help there first about any issues you may be experiencing, or question you might have, before posting on here.
User avatar
glorsplitz
Registered user
Registered user
Posts: 38
Joined: Sun Aug 07 2016 - 22:54:24

shutdown -r turning off rpi

Postby glorsplitz » Sun Jan 15 2017 - 01:31:15

After the 4.4.41-v7+ rpi-update, I shutdown -r now, tried to ssh, no connection, rpi was off.

I've been using rpi-update last few months without any issues.

Not sure what happened. Did a few google searches, what can I look into? Thanks

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 204
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: shutdown -r turning off rpi

Postby Exaga » Sun Jan 15 2017 - 02:15:17

glorsplitz wrote:After the 4.4.41-v7+ rpi-update, I shutdown -r now, tried to ssh, no connection, rpi was off.

I've been using rpi-update last few months without any issues.

Not sure what happened. Did a few google searches, what can I look into? Thanks


Log in locally and take a look at '/etc/ssh/sshd_config' file. Make sure the setting 'PermitRootLogin yes' is specified. See the code below for an example.

Code: Select all

# Authentication:

#LoginGraceTime 2m
PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6
#MaxSessions 10
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
glorsplitz
Registered user
Registered user
Posts: 38
Joined: Sun Aug 07 2016 - 22:54:24

Re: shutdown -r turning off rpi

Postby glorsplitz » Sun Jan 15 2017 - 02:34:04

I don't understand. I always change that to no and log in as regular user then do su - when necessary.

When I issued shutdown -r now as root, which I have been doing when rpi-update does an update, the rpi turned off it did not reboot.

There was no connection because the rpi turned off.

Found these in /var/log/messages
Jan 14 15:34:27 sarpi shutdown[1477]: shutting down for system reboot
Jan 14 15:34:27 sarpi init: Switching to runlevel: 6
Jan 14 15:34:33 sarpi sshd[662]: Received signal 15; terminating.

User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Re: shutdown -r turning off rpi

Postby linicks » Sun Jan 15 2017 - 10:36:05

What does the command:

reboot

do? Does the Pi reboot then?

Nick
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 204
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: shutdown -r turning off rpi

Postby Exaga » Sun Jan 15 2017 - 11:08:23

glorsplitz wrote:I don't understand. I always change that to no and log in as regular user then do su - when necessary.

When I issued shutdown -r now as root, which I have been doing when rpi-update does an update, the rpi turned off it did not reboot.

There was no connection because the rpi turned off.

Found these in /var/log/messages
Jan 14 15:34:27 sarpi shutdown[1477]: shutting down for system reboot
Jan 14 15:34:27 sarpi init: Switching to runlevel: 6
Jan 14 15:34:33 sarpi sshd[662]: Received signal 15; terminating.


Not sure why the RPi isn't (re)booting. 'rpi-update' doesn't usually break things. Although, it's not impossible that the upgrade process didn't go as planned.
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Re: shutdown -r turning off rpi

Postby linicks » Sun Jan 15 2017 - 11:41:15

OK, there is a newer version 4.4.42-v7+ and on my Pi test server reboot works fine after update.

Maybe do another rpi-update?

Nick
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

User avatar
Exaga
FatDog Network Administrator
FatDog Network Administrator
Posts: 204
Joined: Wed Apr 18 2012 - 02:01:03
Location: England [UK]

Re: shutdown -r turning off rpi

Postby Exaga » Sun Jan 15 2017 - 19:01:23

linicks wrote:OK, there is a newer version 4.4.42-v7+ and on my Pi test server reboot works fine after update.


Have you tried the 4.9.x installer/kernel/firmware yet, Nick? :ugeek:
Exaga

====
__ KEEP THE DOG ALIVE!!!
()'`; /
/\|` W00f W00f W00f
www.fatdog.eu

User avatar
glorsplitz
Registered user
Registered user
Posts: 38
Joined: Sun Aug 07 2016 - 22:54:24

Re: shutdown -r turning off rpi

Postby glorsplitz » Sun Jan 15 2017 - 20:30:58

Thanks guys for the tips, figured it out.

Around the time I got my rpi3 and installed sarpi I found http://www.uugear.com/witty-pi-realtime-clock-power-management-for-raspberry-pi/ and thought it would be interesting to try, battery backup, on switch, fan connector. Seems wittypi caused the reboot problem. I thought of trying 'reboot' too and that turned off the rpi too. I disconnected power from the wittypi connected it to rpi 'shutdown -r now' rebooted successfully.

I removed the wittypi, did a couple more halts, reboots, all ok now.

Linux sarpi 4.4.42-v7+ #946 SMP Sat Jan 14 10:14:34 GMT 2017 armv7l BCM2709 GNU/Linux

User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Re: shutdown -r turning off rpi

Postby linicks » Sun Jan 15 2017 - 21:39:10

Exaga wrote:
linicks wrote:OK, there is a newer version 4.4.42-v7+ and on my Pi test server reboot works fine after update.


Have you tried the 4.9.x installer/kernel/firmware yet, Nick? :ugeek:


No, no real time to mess about from scratch - I just use re-images. But today I built latest apache httpd on my test server, works well (I don't like the way the slack package puts stuff all over the place in that build - now all lives in /opt/apache).

I am now building latest stable kernel 4.9.4 on the test server, and when done (I am running in a 'screen' session over ssh as it looks like it will take all night to build) hopefully tomorrow after work I will take a back-up and then install the new kernel ~ then FIREWORKS.

Nick
P.S. as a BTW, we had a power cut last week - power off for 50 minutes (I quickly unplugged everything during the outage). When it all came back, I slowly brought my network back up. My Pi test server was the only one that reported the 'dirty bit' set on /dev/mmcblk0p1 and I scratched my head for a while why my other 4 Pi's didn't. Then I remembered. I don't mount /boot at all - but of course, on my Pi test server I _did_ have it mounted when messing about and forgot to umount it afterwards.

So it is really worth setting /etc/fstab to:

Code: Select all

/dev/mmcblk0p1   /boot            vfat        noauto,fmask=133,dmask=022 1   0

to preserve the boot files.
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

User avatar
linicks
Registered user
Registered user
Posts: 126
Joined: Mon Oct 27 2014 - 20:26:01
Location: Pompey, England

Re: shutdown -r turning off rpi

Postby linicks » Sun Jan 15 2017 - 21:48:09

glorsplitz wrote:Thanks guys for the tips, figured it out.

Around the time I got my rpi3 and installed sarpi I found http://www.uugear.com/witty-pi-realtime-clock-power-management-for-raspberry-pi/ and thought it would be interesting to try, battery backup, on switch, fan connector. Seems wittypi caused the reboot problem. I thought of trying 'reboot' too and that turned off the rpi too. I disconnected power from the wittypi connected it to rpi 'shutdown -r now' rebooted successfully.

I removed the wittypi, did a couple more halts, reboots, all ok now.

Linux sarpi 4.4.42-v7+ #946 SMP Sat Jan 14 10:14:34 GMT 2017 armv7l BCM2709 GNU/Linux


Interesting bit of kit - but reading the control bash scripts on their github site, all it seems to do is startup/shutdown - I couldn't find a 'reboot' script anywhere?

I use these RTC's on all my Pi's:

viewtopic.php?f=30&t=145

EDIT - ignore that link in that link - it's broke - try this for what I use:

https://www.modmypi.com/blog/installing ... time-clock

Nick
https://linicks.net/

Q. What is the difference between a duck and an elephant?
A. You can't get down off an elephant.

Return to “SARPi Project - Slackware ARM on a Raspberry Pi”

Who is online

Users browsing this forum: CommonCrawl [Bot] and 4 guests